Vertikaalzoeken


Verticaal zoeken

 

De meest gebruikte functie in Excel is volgens mij VERT.ZOEKEN(Engels: VLOOKUP) Neem het volgende voorbeeld. Je hebt een tabel ontvangen gegenereerd uit SAP.

vlkup1

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In kolom A vinden we de artikelnummers met voorloopnullen door SAP aangeleverd.De verkoopprijs en het EAN nummer moeten we uit een tweede tabel halen met de verticaal zoek functie VERT.ZOEKEN.

VLKUP2l

In deze tabel zijn een aantal kolommen verborgen voor het beeld. We zoeken met het artikelnummer uit cel A2 uit de eerste tabel naar de verkoopprijs in de tweede tabel op Blad1 in de range(A:AN) de kolom waar we de verkoopprijs moeten vinden is kolom 40 (AN)              =VERT.ZOEKEN(A2);[SOURCEVLKUP.xlsx]Blad1!$A:$AN;40;0)

vlkup3

 

 

 

 

 

 

 

We hebben gezocht met A2 (“000000000000357965”) dit is tekst en we kunnen met tekst niet naar een getal zoeken. Dus de uitkomst is #N/B

vlkup4

Wat nu?

We moeten de tekst omzetten naar een getal met de functie ” GEHEEL(cel;aantal decimalen) “
Die gaan we opnemen in de eerder gemaakte zoekfunctie.
=VERT.ZOEKEN(GEHEEL(A2;0);[SOURCEVLKUP.xlsx]Blad1!$A:$AN;40;0)
Voor de EAN code doen we hetzelfde alléén staat deze info een kolom eerder in 39
=VERT.ZOEKEN(GEHEEL(A2;0);[SOURCEVLKUP.xlsx]Blad1!$A:$AN;39;0)
Wat we hier dan nog moeten doen is de cel eigenschappen aanpassen naar 0000000000000 (13x)

 

vlkup6

vlkup7

vlkup8