Meest gebruikte functies

Meest gebruikte functies: voorbeelden in een formule

Hieronder staan de meest gebruikte functies van Excel.
U ziet steeds
* de opbouw (syntaxis)* wat de functie doet bijvoorbeeld : =SOM(gebied van cellen) Telt de cellen B2 tot en met B14 op.
* voorbeelden in formulevorm:  =SOM(B2:B14)
* het resultaat:    Het totaal van de getallen in B2 tot en met B14.

=AANTAL(zoekgebied)
telt het aantal getallen in het gebied.
=AANTAL(A:A)
geeft weer, in hoeveel cellen in kolom A een getal staat; tekst wordt niet geteld.

=AANTAL.ALS(zoekgebied; getal of “tekst”)
telt in hoeveel cellen van het gebied een getal of tekst staat.

=AANTAL.ALS(D:D; 30)
telt hoe vaak in kolom D het getal 30 voorkomt.

=AANTAL.ALS(D:D; “>30”)
telt in hoeveel cellen in kolom D er een getal staat groter dan 30.

=AANTAL.ALS(D:D; “>”&F1)
telt hoeveel getallen (of datums) in kolom D er groter zijn dan de waarde (of de datum) die u in F1 opgeeft.

=AANTAL.ALS(D:D; “wim”)
telt in hoeveel cellen in kolom D de naam “wim” voorkomt.

=AANTALARG(zoekgebied; getal of “tekst”)
telt in hoeveel cellen van het gebied iets staat (getallen, tekst, datums enzovoort)
=AANTALARG(A:F)
meldt hoeveel cellen in de kolommen A tot en met F gevuld zijn.

=AFRONDEN(getal; aantal decimalen)
rondt het getal af op het opgegeven aantal decimalen.
=AFRONDEN(B13; 2)
rondt het getal in B13 af op twee decimalen.
* Deze functie heette bij de introductie van Excel 2010 tijdelijk AFRONDING.

=ALS(voorwaarde; opdracht als dit waar is; overige gevallen)
geeft de optie die aan de voorwaarde voldoet.
=ALS(D14>0; “Tegoed”; 0)
Als de waarde in D14 groter is dan nul, geeft de formule het woord Tegoed weer, en anders een nul.

=ALS(D14>0; “Tegoed”; “”)
Als de waarde in D14 groter is dan nul, geeft de formule het woord Tegoed weer, en anders niets.

U kunt meer voorwaarden met ALS achter elkaar gebruiken; dit heet nesten.
=ALS(D14>0;”Tegoed”;ALS(D14<0;”Tekort”;””))
Als D14 groter is dan nul, geef dan ‘Tegoed’ weer, als D14 kleiner is dan nul, geef dan ‘Tekort’ weer en anders niets (dus als D14 precies nul is).

=BET(rente per jaar; aantal jaren; eenmalige inleg aan het begin; doelbedrag; 1)
Noteer de eenmalige inleg aan het begin en het doelbedrag als negatieve getallen. De uitkomst is het bedrag dat u per termijn moet storten om het doel te halen.
1 = inleggen aan het begin van de termijn, 0 = inleggen aan het einde van de termijn
=BET(3%;5;0;-6000;1)
Het resultaat is 1.097.
* Deze functie heette bij de introductie van Excel 2010 tijdelijk AFLOSSING.

=DAG(datum)
geeft de dag uit de datum weer, als een getal van 1 tot en met 31.
=DAG(C2)
Met 3-4-2015 in cel C2 is de uitkomst 3.

=DATUM(jaar; maand; dag).
stelt een datum samen met de getallen voor jaar, maand en dag (in deze volgorde).
=DATUM(2015;3;7)
componeert de datum 7 maart 2015.

=DATUMVERSCHIL(oudste datum; nieuwste datum; “y”)
Verschil tussen twee datums in jaren.
=DATUMVERSCHIL(B3; B4; “y”)
Aantal jaren tussen de datums in B3 en B4, afgerond naar beneden.
* “m” op de plaats van “y” geeft het verschil in maanden, afgerond naar beneden.
* “d” op de plaats van “y” geeft het verschil in dagen

=DEEL(cel; beginpunt; aantal tekens)
Het resultaat is een deel van de celinhoud
=DEEL(B1;5;2)
Met ‘Wim de Groot’ in B1 geeft deze ‘de’, vanaf het vijfde teken en dan twee letters.
* Deze functie heette bij de introductie van Excel 2010 tijdelijk MIDDEN.

=GEHEEL(getal)
geeft het hele getal voor de komma weer, negatieve getallen gaan naar boven.
=GEHEEL(3,14159) geeft 3
=GEHEEL(-2,14159) geeft -2

=GEMIDDELDE(gebied)
Het gemiddelde van de getallen in een bepaald gebied.
=GEMIDDELDE(B2:B7)
Het gemiddelde van de getallen in B2 tot en met B7.

=GROOTSTE(gebied; plaats in de ranglijst)
De waarde die staat op de opgegeven plaats in de ranglijst, geteld vanaf de grootste waarde.
=GROOTSTE(B2:B7; 3)
De derde waarde in grootte in B2 tot en met B7.

=HORIZ.ZOEKEN(zoekwaarde; gebied; weer te geven rij)
zoekt in de bovenste rij van het gebied naar de zoekwaarde of kleiner en gaat een opgegeven aantal cellen omlaag (voor een staffel, de waarden in de bovenste rij moeten oplopen).
=HORIZ.ZOEKEN(B8; C3:H5; 3)
zoekt naar de waarde van B8 (of een kleinere waarde) in rij C3 tot en met H3 en geeft de waarde drie rijen onder de gevonden cel, dus uit rij 5.
In dit voorbeeld: zoekt naar 120, stopt bij 101 in F3 en gaat drie rijen omlaag; de uitkomst is 4.

=HORIZ.ZOEKEN(zoekwaarde; gebied; weer te geven kolom; 0 of ONWAAR)
zoekt in de bovenste rij van het gebied exact naar de zoekwaarde en gaat een opgegeven aantal cellen omlaag.
=HORIZ.ZOEKEN(B8; C3:H5; 3; 0) of
=HORIZ.ZOEKEN(B8; C3:H5; 3; ONWAAR)
zoekt naar de exacte waarde van B8 in rij C3 tot en met H3 en geeft de waarde eronder uit rij 5 (drie cellen naar onderen). Nul of ONWAAR zegt dat benaderen niet is toegestaan.

horzkn

 

 

 

 

 

 

 

=INTEGER(getal)
geeft het hele getal voor de komma, negatieve getallen gaan naar beneden.
=INTEGER(3,14159) geeft 3
=INTEGER(-3,14159) geeft -4

=JAAR(datum)
peutert het jaartal uit een datum.
=JAAR(C2)
Staat er 3-4-2015 in cel C2 dan, geeft deze formule 2015.

=KLEINSTE(gebied; plaats in de ranglijst)
de waarde op de opgegeven plaats in de ranglijst, geteld vanaf de kleinste waarde.
=KLEINSTE(B2:B7; 2)
geeft de op een na kleinste waarde in B2 tot en met B7.

=LINKS(cel; aantal tekens)
geeft het linkerdeel van de celinhoud.
=LINKS(B1;5)
Met ‘supersoaker’ in B1 is de uitkomst ‘super’, de eerste vijf tekens

=MAAND(datum)
haalt de maand uit de datum, als een getal van 1 tot en met 12.
=MAAND(C2)
Met 3-4-2015 in cel C2 is de uitkomst 4.

=MAX(gebied)
De grootste waarde in het gebied van cellen.
=MAX(B:B)
geeft de grootste waarde van kolom B.

=MIDDEN(cel; beginpunt; aantal tekens)
Het resultaat is een deel van de celinhoud
=MIDDEN(B1;5;2)
Met ‘Wim de Groot’ in B1 geeft deze ‘de’, vanaf het vijfde teken en dan twee letters.
* Bij de introductie van Excel 2010 heette deze functie tijdelijk MIDDEN, daarna weer DEEL.

=MIN(gebied)
De kleinste waarde in het gebied van cellen.
=MIN(C:C)
geeft de kleinste waarde van kolom C.

=NU()
Datum en tijdstip van dit moment.
=NU()
Uitkomst midden op de langste dag van het jaar is: 21-06-2015 12:00.
* Druk op de F9-toets om de tijd bij te werken.

=PI()
het getal pi op veertien decimalen nauwkeurig.
=PI()
geeft 3,14159265358979.

=RECHTS(cel; aantal tekens)
geeft het rechterdeel van de celinhoud.
=RECHTS(B1;6)
Met ‘supersoaker’ in B1 geeft deze ‘soaker’, de zes tekens aan de rechterkant.

=REST(getal; modulus)
trekt het getal dat u als modulus opgeeft zo vaak mogelijk af en geeft de rest weer.
=REST(12,5;1)
trekt 1 net zo vaak van 12,5 af totdat het restant kleiner is dan 1 en laat de resterende 0,5 zien.
=REST(7;3) geeft 1, hetzelfde resultaat als =7-GEHEEL(7/3)*3.

=SOM(gebied)
telt alle getallen in het gebied op.
=SOM(B2:B11)
geeft het totaal van alle getallen in B2 tot en met B11.

SOM.ALS korte versie
=SOM.ALS(gebied; getal)
Optelsom van alle keren dat dit getal in deze cellen voorkomt.
=SOM.ALS(D1:D18; 50)
telt binnen D1 tot en met D18 elke 50 op.

SOM.ALS lange versie
=SOM.ALS(zoekgebied; getal of “woord”; optelgebied)
Verzamelt alle cellen waarin het gezochte woord (of getal) staat en telt de getallen op in de cellen die daarnaast staan.
=SOM.ALS(E1:E40; ”tanken”; F1:F40)
kijkt waar in E1 tot en met E40 het woord ‘tanken’ staat en telt alle getallen op, die ernaast in F1 tot en met F40 staan.

SOMMEN.ALS kan werken met meer criteria
=SOMMEN.ALS(optelgebied; eerste zoekgebied; eerste criterium; tweede zoekgebied; tweede criterium; enzovoort)
telt uit het optelgebied de getallen op die aan de criteria voldoen.
=SOMMEN.ALS(D:D; A:A;G1; B:B;F2; C:C;H1)
Voorbeeld met drie criteria: de bedragen staan in kolom D, de maanden in kolom A, de namen in kolom B en de plaatsen in kolom C. Als ‘januari’ in G1 staat, én ‘Peter’ in F2, én ‘Den Haag’ in H1, dan worden precies de bedragen in januari, van Peter, in Den Haag, opgeteld.

=SUBSTITUEREN(verwijzing; “te vervangen tekst”; “nieuwe tekst”)
vervangt de opgegeven tekens door andere tekst.
=SUBSTITUEREN(A3;” “;””)
vervangt de spaties in A3 door lege tekst.

=TW(rente per jaar; aantal jaren; jaarlijkse storting; eenmalige inleg aan het begin;1)
geeft het kapitaal dat ontstaat aan het eind van de periode. Storting en inleg noteren als negatieve getallen.
0 = inleggen aan het einde van de termijn, 1 = aan het begin.
=TW(3%;10;-100;-10000;1)
De uitkomst is 14.620.

=VANDAAG()
Datum van de huidige dag.
=VANDAAG()
Geeft in 2015 op Eerste Kerstdag: 25 dec 2015.

=VERT.ZOEKEN(zoekwaarde; gebied; weer te geven kolom)
zoekt in de linkerkolom de waarde of lager en gaat een opgegeven aantal cellen naar rechts (voor staffel, de waarden in de linkerkolom moeten oplopen).
=VERT.ZOEKEN(B14; B6:E11; 4)
zoekt naar de waarde van B14 (of een lagere waarde) in de reeks B6 tot en met B11 en geeft de waarde ernaast uit kolom E (vier cellen naar rechts).
In dit voorbeeld: zoekt naar 17, stopt bij 10 in B8 en gaat vier kolommen naar rechts; uitkomst is 5%.=VERT.ZOEKEN(zoekwaarde; gebied; weer te geven kolom; 0 of ONWAAR)
zoekt in de linkerkolom exact dezelfde waarde en gaat een opgegeven aantal cellen naar rechts.
=VERT.ZOEKEN(B14; B6:E11; 4; 0) of
=VERT.ZOEKEN(B14; B6:E11; 4; ONWAAR)
zoekt naar de exacte waarde van B14 in de reeks B6 tot en met B11 en geeft de waarde ernaast uit kolom E (vier cellen naar rechts). Nul of ONWAAR zegt dat benaderen niet is toegestaan.

vertzkn

 

 

 

 

 

 

=VIND.SPEC(teken;cel)
geeft met een getal aan op welke positie het teken zich bevindt.
=VIND.SPEC(“,”;A2)
Met ‘Jansen, Jan’ in A2 is dit 7: de komma staat op de zevende plaats

=VIND.ALLES(teken;cel)
geeft met een getal aan op welke positie uw teken zich binnen die cel bevindt. Waar VIND.SPEC de asterisk * aanziet voor een jokerteken en altijd een 1 geeft, neemt VIND.ALLES de asterisk letterlijk en geeft aan op welke positie de * in de tekst staat.
=VIND.ALLES(“*”;F3)
Met ‘voor*beeld’ in F3 geeft deze 5, het vijfde teken

=WORTEL(getal)
geeft de vierkantswortel van het getal.
=WORTEL(36)
In dit geval 6.
* Deze functie heette bij de introductie van Excel 2010 tijdelijk VWORTEL.

WEEKDAG(datum)
geeft met een nummer de dag van de week aan; 1 = zondag, 2 = maandag enzovoort.
=WEEKDAG(“1-1-2015”)
geeft een 5, want Nieuwjaarsdag van 2015 viel op donderdag.

=WEEKNUMMER(datum)
geeft het weeknummer van een datum.
=WEEKNUMMER(“17-1-2015”)
geeft een 3.

* Let op: dit gaat volgens de Amerikaanse telling. De formule voor Europese weeknummers is
=(A1-WEEKDAG(A1-1)+4-(GEHEEL(DATUM(JAAR(A1-WEEKDAG(A1-1)+4);1;2)/7)*7-2))/7
In dit voorbeeld staat de datum in A1.